Hace poco hemos tenido un error al actualizar un conocido plugin de WordPress. El error se mostraba en lugar del Slider que se había preparado:
Revolution Slider Error: You have some jquery.js library include that comes after the revolution files js include. This includes make eliminates the revolution slider libraries, and make it not work.

To fix it you can:
1. In the Slider Settings -> Troubleshooting set option: Put JS Includes To Body option to true.
2. Find the double jquery.js include and remove it.

Realmente el problema era otro, pero al dar este mensaje, comprobamos que se cargara todo correctamente. La solución que dan en foros a este problema, y la propia empresa recomienda, es la de actualizar WordPress, desactivar todos los plugins, todos los temas, asignar uno de los que vienen en WordPress por defecto y empezar a probar activando de uno en uno todos los plugins y el tema. Como esta solución no nos convencía mucho, ya que el plugin había funcionado bien hasta su actualización y por otra parte iba a llevarnos horas hacer la comprobación, exploramos otra vía, que resultó ser la solución correcta y que sólo nos llevó 20 minutos:
Abrimos la ventana de Inspeccionar de Chrome y nos fuimos a Console. Allí vimos que el problema real era que no podía cargar las librerías que traía el plugin en su carpeta de revslider/public/… por lo que le asignamos permisos 775 a esas carpetas. A continuación limpiamos todas las cachés, abrimos la web con una sesión de incógnito para cerciorarnos de que el error no se iba a reproducir por un problema de nuestro navegador y todo solucionado.

Esperamos que os ayude!!!

Comparte!
Share

0 comments

Deja un comentario