Hemos actualizado recientemente unas cuantas plataformas de Mautic, de la versión 2 a la 3, y en todas ha terminado pasando lo mismo: necesitaba actualizarse por línea de comandos, y hemos tenido que forzarla, es decir, actualizar la base de datos por un lado y el código por otro, lanzando para ello varias veces upgrade_v3.php –ignore-warnings y limpiando entre uno y otro la caché mediante línea de comandos, y restaurando permisos en las carpetas y archivos.
Si estáis en esta tesitura, os recomiendo que miréis antes de desesperaros el archivo de errores que está en var/logs del propio Mautic, y os dará una pista de qué le está ocurriendo.
Por otro lado, una vez habéis conseguido pasar a la versión 3, os recomiendo que sigáis actualizando (ya estas versiones sí pueden actualizarse a través de la plataforma, sin necesidad de usar la línea de comandos), ya que la última versión corrige muchos pequeños errores de la versión 3.0 y 3.1.
Por último, comentaros que si al entrar en el panel de configuración de Mautic e intentar aplicar los cambios, os devuelve un error como este:
mautic.core.update.archive_no_such_file
La solución es muy simple: id a var/cache y veréis que el directorio prod no tenga los permisos, o usuario o grupo correcto. Corregidlo y todo irá bien.

Comparte!
Share

0 comments

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

A %d blogueros les gusta esto: